
                  Name: ________________________ 

                  Hour: _________________________ 

                  Instrument: ____________________ 

     Music Composition Project 

     Concert Band – Orchestra 

      Solo for your instrument 

Directions: Students will compose an original composition of a minimum of 12 measures. Students may compose more 

than 12 measures, but only the first 12 measures will be graded. Use the rubric below to complete your composition using 

the following components. Students will need an e-mail address (LPS, gmail, yahoo etc.) to complete the project. Be able 

to play what you compose. You will need to play it for the class. *You will also turn in a rough draft copy for Mr. Rais 

to review before you finish your project. First draft due on Friday May 18. You will need to bring headphones into class 

on composing days. Be creative! Have fun!  

Complete your composition online at: http://www.noteflight.com or MuseScore 

Check off list: 

 

_____ 1. Clef: Make sure you have the clef that you read indicated at the start of your piece.  

_____ 2. Key Signature: Choose a key that you are comfortable to play in. (ex. B-flat, D Major) 

_____ 3. Time Signature: You may compose your piece in 2/4, ¾, or 4/4 time. 

_____ 4. Various Rhythms: Use various rhythms such as: whole, dotted-half, half, quarter, eighths, and/or sixteenth notes.  

_____ 5. Various Notes: Use a variety of notes in the key you are writing. Write in a range you can play in. 

_____ 6. Dynamics: Use a variety of dynamics. (f, p, fp, mp, Cresc. Decresc.) 

_____ 7. Articulation: Use of ( . - ) staccato and legato marks, slurs and ties.  

_____ 8. Tempo: In the “Edit Lyricist” write in your tempo (Allegro, Moderato, Allegretto, Andante, etc.) 

_____ 9. Title: Include a title of your composition, be creative and have fun with this! Make sure your name is  

   on the upper right hand side of the page. 

_____ 10. Phrasing/Other: 

 - Orchestra: Use of bowings (Down, Up) 

 - Band: Use of breath marks (‘) 

 - Percussion: Sticking RRLL etc.  

Total points total: 100 points for composition (10 points per check off list item) 

The project is DUE on Friday June 1, 2018 

*Tips: Free accounts use a limited number of instruments so here is what certain instruments need to use… 

Woodwinds: Flute, Oboe, Clarinet, Bassoon, Alto/Tenor Sax (Bari Sax use Alto Sax, Bass Clarinet use Clarinet)   

Brass: Trumpet, Trombone  (French Horn use Trumpet, Tuba use Trombone, Euphonium use Trombone) 

Strings: Violin, Viola, Cello, Bass   Percussion: Rhythm, Drums, Bells=Piano minus the bass clef  

 

http://www.noteflight.com/


Click the "New Score" button at the top of the page to create a score 

NOTEFLIGHT HELP: 
 

Then choose the initial instrument(s) for the score and press OK. 
Select objects and measures by clicking or dragging. 

The prelude to doing anything with an object in the score is always to select it. You can select a note, rest, barline or 

other notations by clicking on it directly: 

 

You can also select a measure specific to a part by clicking in a blank space: 

 

And you can select a section of the score across all parts by clicking in the measure number bar above the score: 

 

You can also select time ranges by clicking and dragging horizontally. 
Enter notes with the mouse 

Click next to the blinking cursor (if you don't see the cursor, click the place where you want it to appear): 

 

By holding the mouse down after you click and dragging from side to side, you can change the duration of the new 

note, making it longer or shorter: 

 



After entering a note, click buttons in the Editing Palette to adjust it: 

 
Enter notes with the keyboard 

Use the letters A through G, and the special keys [Space] and [Backspace]. 

After entering a note, you can adjust it: 

o - + = add a flat, sharp or natural 

o [ or ( makes a note shorter 

o ] or ) makes a note longer 

o , . make ties and dots 

o [Up] and [Down] adjust a note's pitch. 

Add measures 

Move the mouse above any measure and click one of the (+) icons: 

 
Delete measures 

Move the mouse above any measure and click the (-) icon: 

 
 

Move notes or measures from side to side 

Select them, then drag them horizontally and release them in the place you want them to appear. For example: 

 
Use the Sharing panel 

Publish or share your score with other Noteflight users and on the web. 

Score Basics 
Undo and Redo 

All changes that you make to the score can be undone and redone, including changes to the set of selected objects 

or measures. (Undo/redo of selection changes is handy in complex edits since it can take some work to select 

exactly the things you want). The Edit > Undo and Edit > Redo menu commands perform these important 

functions. When you pull down the Edit menu, these menu items also show the names of the actions that they will 

undo or redo if selected:  



 

Up to 20 prior changes are maintained in the edit history. 

The keyboard shortcuts [Ctrl/Command]-Z and [Ctrl/Command]-Y are also available for these commands. 
Saving a score 

The current score may be saved using the File > Save command, also accessed by the keyboard 

shortcut [Ctrl/Command]-S. If there are no changes that need to be saved, this command is disabled. 

Scores are saved automatically when you stop working for a while, or after a predetermined time limit. If you try to 

leave a page with unsaved work, Noteflight asks you to confirm first, in order to avoid losing your changes. 
 

Adding and Editing Notes with the Mouse 

To add a note with the mouse, select the place where you want the note to appear and move the mouse cursor over 

the area just to the right of the blinking insertion point (the thin vertical line). As you move the mouse up and down, a 

gray note head appears under the mouse pointer to show where a note will be placed if you click:  

 

Clicking the mouse button then adds the note head to any note or rest at that position. If any single note or rest is 

already selected when the note was added, the newly added note takes on the time duration of that selected object. 

To control the duration of a new note using the mouse, hold the button down after entering it and drag to either side. 

The cursor will change and its horizontal will start to control the length of the new note. Dragging to the left makes 

the note shorter; dragging to the right makes it longer:  

 

After you add a note, you can also use the Editing Palette to adjust it:  

 
Dragging Notes with the Mouse 

At any point, you can drag one or more selected notes vertically with the mouse to change its pitch. Dragging moves 

all notes one staff line or space at a time (diatonic transposition). 

You can also drag one or more selected notes from side to side with the mouse to change where they fall 

rhythmically within the bar. While you are dragging, the cursor will change to a small note and an orange bar or gray 

outline will travel with the mouse to show where the selected notes will be placed when the mouse button is 



released:  

 
Staff selections 

Staff selections are defined in terms of a time range rather than as a collection of separate objects. A staff 

selection's starting point lies on some note within a bar, and ends on some later note within that bar or a subsequent 

one. Additionally, staff selections (as their name suggests) apply to some set of selected staves, for the duration of 

their time range. Staff selections are good for apply some edit to all notes that lie in a particular time range on some 

set of staves, or erasing a time range in the score. Copying and pasting a staff selection is the best way to copy 

music from one staff (or set of staves) to another. 

You can make staff selections by clicking in the staff within any measure, away from any notes or other objects:  

 

Clicking in the staff and then dragging horizontally selects a range of measures on that staff, rather than a single 

measure. 

To select an entire staff throughout the whole score, you can also click the gray "staff marker" that appears to the 

left of the starting point of each staff: 

 

Double clicking in any staff also selects that entire staff . 

The Editing Palette 

Once selected, a note, chord or rest or other notation can be manipulated with the editing palette. This palette is 

only shown when there are one or more objects. Its contents depend on what kind of objects are selected. The 

palette moves around to position itself near the first selected object, but you can move it yourself to any location you 

like. 
The Basic Palette 



When one or more notes are selected, the palette has two parts: the Basic Palette and a set of Advanced Palettes. 

Normally the Advanced palettes are closed, and the Basic palette is shown by itself:  

 

Editing actions available from the Basic palette include: 

 

Sharps, flats and naturals 

 

Rhythm duration changes 

 

Addition of lyrics, text, expression/dynamics or chord symbols 

 

Fermatas, augmentation dots and ties 

 

Delete selected objects 

Clicking on any of the tabs at the bottom of the Basic palette allows you to choose an Advanced palette to work with. 

We'll describe these Advanced palettes one at a time. 
Advanced Palette: Symbols 

 

Select notes or chords prior to clicking the actions on this palette, which include: 

 

These buttons add an articulation symbol to the selected notes including accents, bowing and open/closed. 

 

The Slash symbol converts the selection to use a slash notehead and advances the note entry cursor. The / key 

is a shortcut for this action. 

 

The Segno symbol adds a segno symbol to the musical form at the current selection. 

 

The Coda symbol adds a coda symbol to the musical form at the current selection. 

 

The Repeat Ending symbol adds a repeat ending to the musical form at the current selection. You can double-

click the number to edit it. Multiple numbers separated by commas are allowed. 



 

This button adds system text at the current selection. System text is like regular text, except that it is 

associated with all parts in a measure, and it always appears above the topmost part in the score. The [Shift]-

T key is a shortcut for this action. 

 

This button toggles the currently selected note between a plain note and a double-dotted note (one and three-

quarters of the length that the note would have without the double-dot). 

 

This button creates a caesura on the selected note, used to denote a substantial pause in the music. 

 

This button creates a breath mark on the selected note, used to denote a pause where the performer draws 

breath or pauses briefly. 

 

This button adds, modifies or removes an arpeggio on the currently selected chord. Arpeggios may be notated 

without an arrow (in which case they are played upwards) or with an arrow going up or down. Noteflight does 

not currently support cross-staff arpeggios in keyboard music. 

 

These buttons add/remove a mordent or inverted mordent. Noteflight does not play mordents, but they are 

commonly performed as a short two-note trill above or below the main note respectively. 

 

These buttons add, modify or remove a turn or inverted turn. Clicking once adds a regular turn, while clicking 

again converts it into a delayed turn that is performed a short time interval into the note. Clicking a third time 

removes the turn. Noteflight does not play these ornaments. 

Advanced Palette: Note Styles 

 

Select notes or rests prior to clicking the actions on palette, which include: 

 

A full range of note shapes, including some without stems. 

 

The Cue icon allows you to toggle the size of notes or rests to a smaller size used for parts that 

indicate what some other instrument is playing, called a "cue". 

 

The Stems Up and Stems Down icons allow you to toggle the direction of note stems to force 

them to always go up or always go down, instead of being automatically positioned by Noteflight. 

Advanced Palette: Lines 

 



Actions available from this palette affect a range of music in a staff, usually more than a single note. Select the 

range of music you want to affect by dragging, selecting measures, or shift-clicking before choosing from the 

following: 

 

Hairpin dynamics for crescendo and diminuendo 

 

Slurs 

 

Trills  

 

Multiple Measure Rests 

 

Lines representing ranges of music for crescendo (cresc.), diminuendo (dim.), accelerando (accel.), 

ritardando (rit.) and let vibrate (l.v.) 

 

A wavy line indicating vibrato. 

 

Lines that cause the music to be sounded one octave lower (8vb) or higher (8va) than written. 

 

Pedal notation permitting all notes to ring indefinitely. 

 

General purpose dashed or solid lines. 

 

General purpose brackets. 

Repeating Music 

A special case of using Copy and Paste is when a section of music is to be repeated, possibly with some 

modification. Repeated music is very common, ranging from a single note to a melodic theme to entire sections of 

the score. 

To make this operation easier, there is a special Edit > Repeat command (shortcut key R) which duplicates the 

selection and immediately pastes a copy of the selection after itself, without affecting the contents of the clipboard. 

Transposing Music 

To change the key of one or more notes in your score, select some music and use one of the entries on the Edit > 

Transpose menu, which offers a number of options: 

o Up Scale Step and Down Scale Step (shortcuts: Up and Down). Move the selected notes up or down by one staff position, 

using the current key signature. This type of transposition is most useful for music with no accidentals. 

o Up Half Step and Down Half Step (shortcuts: [Shift]-Up and [Shift]-Down). Transpose the selected notes up or down by a 

chromatic step adding sharps or flats as needed. Sharps are preferred when transposing up, flats when transposing down. If you 

don't get the accidental you want, transpose one extra half-step and then come back in the opposite direction. 

o Up Octave and Down Octave (shortcuts: [Ctrl]-Up and [Ctrl]-Down). Transpose the selected notes up or down one octave. 

o Up Interval and Down Interval. Transpose the selected notes up or down by the interval that you choose. This is the only 

transposition command which will affect the key of selected chord symbols. 

The Edit > Enharmonic Change command will "flip" the accidentals of all selected notes, changing sharps to flats 

and vice versa, without changing the pitch of the notes. It is very useful when correcting notes imported from MIDI. 

https://www.noteflight.com/guide#hairpins
https://www.noteflight.com/guide#slurs
https://www.noteflight.com/guide#trills
https://www.noteflight.com/guide#multiRests
https://www.noteflight.com/guide#otherLines


Adding Measures 

You can add a new measure to the score by selecting a measure and clicking one of the "+" icons that appears to 

the left or right of its measure marker; this adds a new measure before or after the selected measure respectively:  

 

Another way to add measures is to make a score selection, use the Cut or Copy command, and then use Paste to 

insert the score selection after the measure containing the current selection. 

Yet another way to add measures is to make a score selection and use the Repeat command to duplicate it. The 

new copy is placed directly after the original. 

Removing or Clearing Measures 

To delete one or more measures from the score, create a score selection by clicking a numbered measure marker, 

then Shift-click elsewhere in the score to extend the selection to more measures if needed. Then press 

the [Delete] key, or use the Edit > Delete menu item. 

To clear out the contents of a measure without removing it from the score, create a staff selection by clicking in the 

staff area of a measure and using Shift-click in another staff area to extend the selection if desired. Then press 

the [Delete] key, or use the Edit > Delete menu item. 

Key Signatures, Time Signatures and Clefs 

Tutorial Video 
Changing Key Signatures 

To change an existing key signature, click it. To apply a key signature to the entire score, use the Staff > Change 

Key Signature... command. (If you only want to affect a range of measures, select those measures first.) A dialog 

allows you to specify the new key signature in terms of sharps or flats to apply to the selected range, and to also say 

http://www.youtube.com/watch?v=n1GxmGkTrmA


what scale you are using:  

 

The labels under each choice give the name of the key for the scale that is selected, which by default is Major. 

Change the scale to another choice such as Minor or Lydian and the labels will change accordingly. 

There is one special button labeled ?, which means a key signature with no accidentals and no specified key. This 

key signature is considered atonal, and will have no accidentals even in a transposed score. 

To change a key signature and all the bars following it up to the next key change, or the end of the score, simply 

click the key signature to edit it. 
Changing Time Signatures 

To change an existing time signature, click it. To apply a time signature to the entire score, use the Staff > Change 

Time Signature... menu command. (If you only want to affect a range of measures, select those measures first). 

A dialog then appears which allows you to specify the new meter to apply to the selected range:  

 

Clicking the common time  or cut time  symbol buttons on the right allows you to specify these symbols to be 

used for the time signature instead of the normal number fraction form. When selected, these automatically force 

time signatures of 4/4 and 2/2 respectively. 

There are three modes for time signature changes: 



o Normal (the default): the time signature in the selected measures is changed to the specified number and type of beat, and the 

visible time signature is adjusted to reflect the change. 

o Pickup: a single pickup bar is created with the specified number and type of beats, and contains the portion of the selected 

music immediately preceding the last barline in the selection. The visible time signature is not adjusted. 

o Hidden: the time signature in the selected measures is changed to the specified number and type of beat, but the visible time 

signature is not changed. 

When you change the time signature of a range of measures using the Normal or Hidden modes, no music is lost. 
The existing notes in the selected range of the score are rebarred to fit the new time signature's bar lines. As a 
result, you may wind up with a larger or smaller number of bars than you had before you made the change. 

Pickup Bars (anacruses) and Irregular Measures 

There are a number of situations in which measures do not have as many beats as the current time signature 

implies. The most common case is a pickup bar or anacrusis in which the music starts in the middle of a bar. 

To create such a feature in Noteflight, use the Staff > Change Time Signature... command to change the time 

signature of the bar to the actual number of beats that you want to appear in the bar, and select the button 

labeled Pickup. This causes the measure to contain the desired number of beats, but leaves the notated time 

signature as it was before. 

Let's look at these steps in a little more detail. First, select the measure that you want to turn into a pickup measure:  

 

Next, change the time signature using Pickup mode. Here, we select a time signature of 1/4 because we want a 

pickup measure consisting of a single quarter note:  

 



The result is a pickup measure with a single beat of music, but which preserves the overall 3/4 time signature of the 

piece:  

 
Changing Clefs 

To apply a clef to a range of measures, a portion of some staff, or even a single note, make the appropriate 

selection and use the Staff > Change Clef... command. A dialog is offered allowing selection of the clef to be 

applied to the range:  

 

To change the clef for an entire staff within the score, click that staff's clef at the start of any system. 

To change the clef for a specific sequence of music beginning with an existing clef change and continuing up to the 

next clef change, click the clef change notation at the start of that sequence. 

Clef changes may be cut, copied, pasted and deleted. To cut, copy or delete a clef change, first select the 

surrounding material (a clef by itself cannot be selected). When pasting, the Score Editor makes the appropriate 

changes, inserting clef changes as needed to preserve the correspondence of the music and the notation. 
 


